Unable to integrate the chatbot with the client/Mobile Channel Please Help us

We are using travel planning sample bot for practicing the chatbot implementation with sdkApp.
we chose HS256 algorithm and jwtURL as “http://localhost:3000/api/users/sts”. we are getting following error in node console. browser is displaying “respond with a resource” message.

Failed to lookup view “error” in views directory “D:\dev\SDKApp\sdk”.

Even we tried with “http://demo.kore.net/users/sts” but no luck. This time browser is displaying follwoing message “Cannot GET /users/sts”

Can you please help me in resolving this issue.

Thanks in advance

Hello @siripurapurahul,

Have you started the SDK App? You will need to open command prompt
cd “D:\dev\SDKApp” (Hope this is where you have the SDKApp unzipped)
npm install (If you have not done this step before)
node startServer (Ensure there is startserver.js)

After this you should be able to get rid of the “Cannot GET /users/sts” message.

Hope you have referred to the thread Facing issue while integrating bot with web/mobile client channel
If you face any further problem, please post in that thread.

1 Like

Hello @swagata.sengupta I am using Kore Web SDK app downloaded it and unzipped it as well in the place D;/dev/SDKApp/sdk as specified in the steps. ran a npm install in the path D;/dev/SDKApp after that started the app using node startServer.js command I am sharing my index.html please look into it and help us solve this issue as soon as possible , By the way i have gone through the steps specified in Facing issue while integrating bot with web/mobile client channel we are basically facing the issue with the JWT Url we are using demo.kore.net url as we are using kore web sdk app , I am enabling the bot only for consumers use so i have put isAnonymous as true
screenshot1 screenshot2 screenshot3_LI screesnhot4


At a first glance nothing looks too different from the set up I have. There could be a possibility that some resources are missing.

Also, the error

Failed to lookup view “error” in views directory “D:\dev\SDKApp\sdk”.

should not stop you from connecting to the bot. This is just a route error in node.js.

I just did the entire set up again to ensure nothing is amiss and I do not see any problem with our latest SDKApp and WebSDK.

  1. Downloaded SDKApp from as mentioned in web sdk tutorial.
  2. Downloaded zip of Kore web SDK from GitHub.
  3. Unzipped the contents of SDK into UI directory of SDK app image
  4. npm install at the SDKApp diretory.
  5. node startserver
  6. index.html set “isAnonymous”: true
  7. Updated the bot name, id, client secret, client id etc.
  8. Served the index.html through http://localhost:3000/UI/
  9. I am able to connect to the bot.

Please try the above and let us know.

Note - You can check if JWT service is running (from SDKApp) properly by serving the JWT URL directly.

If the above does not work for you, please let us know if you see any error under F12 (developer console - assuming chrome) > Console/ Network while trying to connect to the bot/ serving the index.html.


@swagata.sengupta Thanks a lot for the explanation given by you it solved all my issues, I will get back to you if I face anymore.